[afnog] DHCP configuration on cisco router 2600 series

Jim Forster forster at cisco.com
Sat Sep 10 01:07:04 EAT 2005


I think the issue is that you're issuing the "ip dhcp pool" command  
while in config-interface mode.   The pools are not directly  
connected to inferfaces, but rather when dhcp request come in on an  
interface the appropriate pool is then utilized.


It's more like this:

ip dhcp pool nonCiscoClients
    network 10.0.1.0 255.255.255.0
    default-router 10.0.1.1
    dns-server 206.13.31.12 206.13.28.12
    domain-name sbcglobal.net
!
interface FastEthernet0
ip address 10.0.1.1 255.255.255.0


My actual config at home is more complicated, as I allocate IP's from  
different subnets depending on the Mac address (not a particularly  
elegant solution, but for a small scale net that doesn't change  
often, it's easy).

ip dhcp pool nonCiscoClients
    import all
    network 10.0.1.0 255.255.255.0
    default-router 10.0.1.1
    dns-server 206.13.31.12 206.13.28.12
    domain-name sbcglobal.net
!
ip dhcp pool JimsAP
    host 10.0.1.6 255.255.255.0
    client-identifier 0100.4096.41bd.73
!
...
interface FastEthernet0
description inside interface
ip address 10.0.1.1 255.255.255.0 secondary
ip address 10.32.245.241 255.255.255.240


   -- Jim


On Sep 9, 2005, at 9:52 AM, Paul wrote:

> Good day,
> am still having problem with the dhcp config on my router,
> below is the error am getting again after doing what u said i  
> should type no ip domain lookup.
> sorry am I suppose to setup the dhcp on the ethernet interface or  
> on the global configuration.
> RSUST-EDUPORTAL(config-if)#ip dhcp pool RSUST-LAN
> Translating "pool"
>                                ^
> % Invalid input detected at '^' marker.
> RSUST-EDUPORTAL(config-if)#   network 192.168.200.0 255.255.255.0
>                                  ^
> % Invalid input detected at '^' marker.
> RSUST-EDUPORTAL(config-if)#   default-router 192.168.200.1
>                                      ^
> % Invalid input detected at '^' marker.
> RSUST-EDUPORTAL(config-if)#   dns-server 81.199.0.36 81.199.3.7
>                                ^
> % Invalid input detected at '^' marker.
>
> thnaks
> Aj
>



More information about the afnog mailing list